Médaille
N°1 pour apprendre & réviser du collège au lycée.
Statistiques à l'aide d'un tableur

Déjà plus de

1 million

d'inscrits !

Avant de commencer, regarde la vidéo

Introduction :

Un tableur est un logiciel qui permet de construire des tableaux, d'effectuer des calculs dans ces tableaux et de traiter un grand nombre de données. On peut notamment automatiser des calculs en insérant des formules qui utilisent l'adresse des cellules. Ce cours a pour objectif d'apprendre à utiliser un tableur (Microsoft Excel ou OpenOffice Calc) pour calculer les caractéristiques d'une série statistique.

Nous allons commencer par présenter l'exemple qui nous servira de base de calculs. Nous apprendrons d'abord à calculer la moyenne d'une série de données brutes (non regroupées par valeurs et effectifs). Nous verrons ensuite comment calculer la moyenne de données organisées dans un tableau des effectifs par l'utilisation de la moyenne pondérée.

Objet de l'étude

Comme exemple de base, nous allons prendre la série de données suivante qui représente les températures maximales relevées les deux premières semaines de juillet 2016 à Toulouse :

292226312930323231362419222229 - 22 - 26 - 31 - 29 - 30 - 32 - 32 - 31 - 36 - 24 - 19 - 22 - 22

On calculera d'abord la moyenne de cette série de données brutes à l'aide d'un tableur.
Nous créerons ensuite le tableau des effectifs de cette série afin d'en calculer la moyenne par la méthode de la moyenne pondérée.

Moyenne d'une série de données

Création du tableau dans une feuille de calcul du tableur

Il s'agit d'abord de renseigner dans la 1re  colonne les données brutes en réservant la cellule du haut pour le titre : la 1re sera « Températures max en °C ». Nous nommerons la 2e colonne « Moyenne en °C ».

Nous obtenons le tableau ci-après :

Statistiques à l’aide d'un tableur mathématiques cinquième

Calcul de la moyenne

Pour calculer la moyenne d'une série de données, on utilise la fonction moyenne du tableur dont la formule est la suivante :

=MOYENNE(cellule de début:cellule de fin)

Dans notre exemple, nous devons calculer la moyenne des données depuis la cellule A2 jusqu'à la cellule A15 et souhaitons inscrire le résultat dans la cellule B2 :

  • Dans la cellule B2 :

on saisit =MOYENNE(A2:A15)
ou
on saisit =MOYENNE(
puis on sélectionne la cellule A2 et, sans lâcher la souris, on se déplace jusqu'à la cellule A15, puis on lâche la souris.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • En validant (touche Entrée), on obtient :

Statistiques à l’aide d'un tableur mathématiques cinquième

D'où le tableau suivant :

Statistiques à l’aide d'un tableur mathématiques cinquième

  • La moyenne des températures des 2 premières semaines de juillet 2016 est donc égale à 27,5 °C.

Moyenne pondérée de données organisées

Création du tableau des effectifs

Notre série de données brutes est :

292226312930323231362419222229 - 22 - 26 - 31 - 29 - 30 - 32 - 32 - 31 - 36 - 24 - 19 - 22 - 22

Organisée par valeurs et effectifs, nous obtenons le tableau suivant :

Températures en °C
(valeurs)

1919 2222 2424 2626 2929 3030 3131 3232 3636

Nombre de jours
(effectifs)

11 33 11 11 22 11 22 22 11

Dans le tableur, il s'agit donc d'entrer non plus la liste des températures relevées mais les valeurs prises par le caractère « Température » et de rajouter une colonne « Nombre de jours (effectif) ».

Nous obtenons le tableau suivant :

Statistiques à l’aide d'un tableur mathématiques cinquième

Calcul de la moyenne pondérée

Dans un tableur, il n'existe pas de formule toute prête pour calculer une moyenne pondérée. Un moyen d'y parvenir est d'utiliser la définition de la moyenne pondérée.

bannière definition

Définition

Moyenne pondérée :

La moyenne pondérée d'une série statistique est égale à la somme des valeurs pondérées par leur effectif respectif divisée par l'effectif total.

bannière definition

Définition

Valeur pondérée :

Une valeur pondérée par son effectif est le produit de cette valeur par son effectif.

Méthodologie

Il s'agira donc de calculer :

  • l'effectif total de la série (somme des effectifs),
  • les valeurs pondérées (valeur × effectif),
  • la somme des valeurs pondérées,
  • la moyenne pondérée (somme des valeurs pondérées/effectif total).

Reprenons notre exemple et décidons de calculer :

  • l'effectif total dans la cellule B13
    (titre en B12)
  • les valeurs pondérées en C2, C3…, C10
    (titre en C1)
  • la somme des valeurs pondérées en C13
    (titre en C12)
  • la moyenne pondérée en D13
    (titre en D12)

Statistiques à l’aide d'un tableur mathématiques cinquième

  • L'effectif total est la somme des effectifs.

La fonction somme du tableur a pour formule :

=SOMME(cellule de début:cellule de fin)

Dans notre exemple, nous devons calculer la somme des effectifs de la cellule B2 à cellule B10 et inscrire le résultat dans la cellule B13.

  • Dans la cellule B13 :

on saisit =SOMME(B2:B10)
ou
on saisit =SOMME(
puis on sélectionne la cellule B2 et, sans lâcher la souris, on se déplace jusqu'à la cellule B10, puis on lâche la souris.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • En validant (touche Entrée), on obtient :

Statistiques à l’aide d'un tableur mathématiques cinquième

  • L'effectif total de la série est égal à 14 jours.
  • Une valeur pondérée par son effectif est le produit de cette valeur par son effectif.
bannière à retenir

À retenir

Dans le tableur, l'opération « × » se traduit par « * ».

Calculons en C2 la valeur pondérée correspondant à la valeur 19 (cellule A2) d'effectif 1 (cellule B2).

  • Dans la cellule C2 :

on saisit = A2*B2
ou
on saisit =
puis on sélectionne la cellule A2, puis on saisit *, puis on sélectionne la cellule B2.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • En validant (touche Entrée), on obtient :

Statistiques à l’aide d'un tableur mathématiques cinquième

  • La valeur pondérée correspondant à la valeur 19 est 19.

Pour effectuer le même type de calcul de la cellule C2 à la cellule C10 :

  • On sélectionne la cellule C2.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • On clique sur l'angle en bas à droite et sans lâcher la souris on tire la sélection jusqu'à la cellule C10.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • En lâchant la souris, on obtient les résultats ci-contre.

Remarque
Le tableur effectue le même calcul de la cellule C2 à la cellule C10 en changeant simplement l'adresse des cellules en fonction du numéro de la ligne : pour la cellule C3, il calcule =A3*B3, pour la cellule C4, il calcule =A4*B4… jusqu'à la cellule C10 où il calcule =A10*B10.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • La somme des valeurs pondérées est ici égale à la somme des cellules C2 à C10 :

  • Dans la cellule C13 :

on saisit =SOMME(C2:C10)
ou
on saisit =SOMME(
puis on sélectionne la cellule C2 et, sans lâcher la souris, on se déplace jusqu'à la cellule C10, puis on lâche la souris.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • En validant (touche Entrée), on obtient :

Statistiques à l’aide d'un tableur mathématiques cinquième

  • La somme des valeurs pondérées est égale à 385.
  • La moyenne pondérée est le quotient de la somme de valeurs pondérées par l'effectif total
bannière à retenir

À retenir

Dans le tableur, l'opération « ÷ » se traduit par « / ».

Dans notre exemple, il faut diviser le contenu de la cellule C13 par le contenu de la cellule B13 et inscrire le résultat dans la cellule D13.

  • Dans la cellule D13 :

on saisit = C13/B13
ou
on saisit =
puis on sélectionne la cellule C13, puis on saisit /, puis on sélectionne la cellule B13.

Statistiques à l’aide d'un tableur mathématiques cinquième

  • En validant (touche Entrée), on obtient :

Statistiques à l’aide d'un tableur mathématiques cinquième

Nous obtenons ainsi le tableau final suivant :

Statistiques à l’aide d'un tableur mathématiques cinquième

Conclusion :

Dans ce cours, nous avons appris à calculer la moyenne d'une série de données brutes en utilisant la fonction du tableur dont la formule est =MOYENNE(… : …).

Dans le cas d'une série de données organisées, nous avons appris à calculer la moyenne en utilisant la définition de la moyenne pondérée. Ainsi, nous avons vu l'utilisation de la fonction somme dont la formule est =SOMME(… : …) ainsi que celle des opérateurs « × » (traduit par « * ») et « ÷ » (traduit par « / »).

Nous avons également vu comment répéter une opération identique sur plusieurs lignes consécutives grâce à la technique de la sélection étendue.